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This chapter briefly describes some CiscoWorks applications and provides instructions on how to use
them. It also contains an overview of how CiscoWorks functions with your network management
platforms. The chapter includes the following sections:

• CiscoWorks Online Help

• Learning to Use CiscoWorks

• Getting Started with CiscoWorks on SunNet Manager

• Getting Started with CiscoWorks on HP OpenView

• Security Options

For detailed CiscoWorks application information, refer to the CiscoWorks online help system.

CiscoWorks Online Help
CiscoWorks now includes a new form of online help based upon help systems supplied with
Windows-based platforms. It replaces theCiscoWorks User Guide, which is no longer supplied with
CiscoWorks.

Once you start the CiscoWorks online help system, you can jump to any topic within the system. For
information on how to use the Help viewer, selectHelp>How to Use Help when the first help
window appears.

Online help is available from several parts of CiscoWorks and its network management platforms:

• Network management platform menus, so you can view help before starting a CiscoWorks
application.

• CiscoWorks application Help menus which start the help system and display the Contents page
for that application.

• CiscoWorks Toolbox application so you can view help before starting a CiscoWorks application.

CiscoWorks online help includes aFind button that allows you to do full-text searches within the
help system. For information on how to do a search, selectHelp>How to Use Help when the first
Help window appears.
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Viewing Online Help
The online system includes help descriptions for all CiscoWorks menus and windows, including
windows that do not haveHelp menus. You can view your online help system in the following ways:

• StartingCW - Application Help from your NMS platform menus.

— To view CiscoWorks online help from SunNet Manager, selectTools>CW - Application
Help. The CiscoWorks Help Contents window opens.

— To view CiscoWorks online help from HP OpenView, selectHelp>CW - Application Help.
The CiscoWorks Help Contents window opens.

• Starting help from inside a CiscoWorks application.

— SelectHelp>On window_name from any CiscoWorks window that has aHelp menu. The
CiscoWorks Help Contents for that application opens.

• Starting help from the CiscoWorks Toolbox application:

— Press theF1 key while pointing to a CiscoWorks application icon in the Toolbox window.
The CiscoWorks Help Contents for that application opens.

• To get help for a window that does not have aHelp menu or get help for a menu:

— Start the Help system for that application from a window that has aHelp menu, or use one
of the other methods for starting the help system.

The Contents page for each application, titled “UsingApplication_name,” includes
highlighted jumps to topics containing lists of all the windows and menus for that
application.

— Click on the highlighted jumps,Application_name Windows orApplication_name Menus,
for information on windows and menus.

Learning to Use CiscoWorks
CiscoWorks applications appear on your network management platform menus. To use CiscoWorks
features and your NMS software to the fullest, you must understand how to start the applications and
complete some basic tasks. This section describes the location of the CiscoWorks applications on
the NMS menus and provides an overview of the post-installation tasks to complete before you
begin to use CiscoWorks.

CiscoWorks Applications
Table 6-1 lists the CiscoWorks applications and their menu locations, and explains the tasks they
perform. The CiscoWorks applications are listed in alphabetical order.

In SunNet Manager, start the CiscoWorks applications via theTools andGlyphs menus. In HP
OpenView, start the CiscoWorks applications through any of the standard menu options
(Administer, Monitor , Diagnose, orMisc).
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Table 6-1 Accessing CiscoWorks Applications from Your NMS Platform

SunNet Manager
Menu Location

HP OpenView Menu
Location Tasks

Tools>CW -
Application Help

Help>CW - Application
Help

CiscoWorks online help system that allows you to
investigate different levels of details within the online
help system by selecting highlighted text to open
additional windows. The online help system provides
overview, related information, procedures, and glossary
data on the CiscoWorks applications and features. It
allows both keyword and full-text searches to enable
users to search for specific text.

Tools>CW -
AutoInstall Manager

Administer>Cisco
Devices>CW - AutoInstall
Manager

Remotely deploy a new router using a neighbor router.
Perform AutoInstall tasks remotely by running
CiscoWorks instead of a Telnet session.

Tools>CW -
CiscoConnect

Administer>CW -
CiscoConnect

Creates detailed customer network profiles, allows for
automatic submission of Cisco cases to the Technical
Assistance Center (TAC), and allows you to check the
status of existing cases and add information to them.
CiscoConnect uses a Mosaic HTML-1.0 compliant
browser and HTTPD server, sending and receiving
e-mail over the Internet to Cisco.

Tools>CW - CiscoView Monitor>CiscoView Allows you to view the front and rear panels of Cisco
devices. You can display configuration and performance
information for the device, its cards, and its ports. You
can use this information to monitor network
performance, quickly access vital device information,
and troubleshoot minor network problems.

Tools>CW -
Configuration
Management

Administer>Cisco
Devices>CW -
Configuration Management

Access configuration files of local and remote Cisco
Systems devices to analyze or edit as necessary.
Compare the contents of two configuration files in the
database, or compare the configuration currently running
on a device with the configuration that represents the last
Database to Devicecommand you performed.

Tools>CW -
Configuration Snap-In
Manager

Administer>Cisco
Devices>CW -
Configuration Snap-In
Manager

Create and execute selected or custom UNIX commands
on a device or group of devices at any time with Global
Command Scheduler.

Glyph Tools>CW -
Contacts

Monitor>Description>CW
- Contacts

Obtain information about the contact for a specific
device, including the complete name, phone number,
e-mail address, title, location, and address of the person
responsible for the operation of the device.

Tools>CW - Device
Management

Administer>Cisco
Devices>CW - Device
Management

Create and maintain a database that holds a complete
inventory of your network—hardware, software, release
levels of operation components, individuals responsible
for maintaining the devices, and associated locations.
Enter or change data in the database tables for network
devices, networks, interfaces, contacts, vendors, and so
on.

Tools>CW - Device
Monitor

SunNet Manager only Monitor your network devices for information about
environmental and interface statistics. Specify how often
CiscoWorks should check this information.
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Tools>CW - Device
Polling

Monitor>CW - Device
Polling

Probe and extract information about the condition of
your networks using a polling feature. Information
acquired is stored in the database for further evaluation
and analysis. Compare the relative performance and
status of devices and interfaces on the network.

Glyph Tools>CW -
Device Software
Manager

Administer>CiscoWorks
Software Images>CW -
Device Software Manager

Automate the upgrade of a system software or
microcode image on a Cisco device.

Tools>CW - Domain
Manager

Administer>CiscoWorks
Security>CW - Domain
Manager

Create groups of devices (called domains) that
CiscoWorks applications can use to accomplish network
management tasks such as security, configuration, and
device polling.

Glyph Tools>CW -
Environmental Monitor

Monitor>CW -
Environmental Monitor

View the environmental status of Cisco AGS+ and Cisco
7000 routers including temperature and voltage
statistics. This function is available on AGS+ routers
running System Software Release 9.0 or later with an
environmental monitor card running ENVM Microcode
Version 2.0 or later.

Tools>CW - Global
Command Manager

Administer>CiscoWorks
System>CW - Global
Command Manager

Create, store, and execute system commands on a device
or group of devices at any time with Global Command
Scheduler.

Tools>CW - Global
Command Scheduler

Administer>CiscoWorks
System>CW - Global
Command Scheduler

Schedule commands or other jobs at regularly scheduled
times using thecrontab utility.

Glyph Tools>CW -
Health Monitor

Monitor>CW - Health
Monitor

View information about the status of a device, including
buffers, CPU load, memory available, and protocols and
interfaces being used. Enables you to display the Show
Commands and Real-Time Graphs windows from the
Health Monitor window.

Tools>CW - Login Misc>CW - Login Perform a generic login for all CiscoWorks applications
that require user authentication so that you do not have
to log into each application separately.

Tools>CW - Logout Misc>CW - Logout Log out of secured CiscoWorks applications to ensure
security for those applications with authority checking
turned on.

Tools>CW - Path Tool

OR

Glyph Tools>CW - Path
Tool

Diagnose>Network
Connectivity>CW - Path
Tool

View and analyze the path between two devices. Perform
analysis on the path to collect utilization and error data.
Displays the devices encountered between the source
and the destination device, the link speeds connecting
these SNMP devices, and the interface names.

Tools>CW - Polling
Summary

Monitor>CW - Polling
Summary

Summarize the polling setup completed within Device
Polling. Browse data, and stop and start polling.

Tools>CW - Process
Manager

Administer>CiscoWorks
System>CW - Process
Manager

Start, stop, and view status of CiscoWorks-related
processes including Polling (nmpolld), CiscoConnect
(httpd ), System Log (syslogd), Sybase Server
(dataserver), and TACACS (xtacacsd) daemons.

SunNet Manager
Menu Location

HP OpenView Menu
Location Tasks
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Glyph Tools>CW -
Real-Time Graphs

Monitor>CW - Real-Time
Graphs

View device information such as the router health (buffer
space, CPU load, environment, free memory, and
security); interface health (bits per second, bytes, errors,
packets per second, packets, and queues); and protocol
traffic (IP, ICMP, SNMP, TCP, UDP, AppleTalk, DECnet
IV, Novell, VINES, and XNS) using a grapher utility.

Tools>CW - SA
Password

Administer>CW -
Security>CW - SA
Password

Log in to the Sybase database account so you can
perform system administrator tasks.

Tools>CW - Security
Manager

Administer>Security>CW -
Security Manager

Create authority checking procedures to protect selected
CiscoWorks applications and network devices from
unauthorized individuals by requiring a login to use
protected applications. This protection ensures that only
users with a valid account and password can perform
tasks such as configuring a router, deleting database
device information, or defining polling procedures.

Glyph Tools>CW -
Show Commands

Diagnose>CW - Show
Commands

View device data about any SNMP device, including
Cisco routers and communication servers. This data
includes the software version, buffers, selected device
interfaces, traffic mix, IP accounting checkpoint, ARP,
and IP route. Emulates the EXECshow commands for
Cisco routers.

Tools>CW - Software
Inventory Manager

Administer>
CiscoWorks Software
Images>CW - Software
Inventory Manager

Update the Sybase database to include current device
software and hardware status. Sort device information
according to platform and software image, and invoke
Device Software Manager to update specific devices.

Tools>CW - Software
Library Manager

Administer>CiscoWorks
Software Images>CW -
Software Library Manager

Maintains a master storage area that contains a list of all
available Cisco system software. These Cisco IOS
software images are retrieved by the user with a variety
of methods.

Tools>CW - Sync
w/Sybase

or

Glyph Tools>CW -
Sync w/Sybase

Misc>CW - Sync w/Sybase Synchronize the NMS and Sybase databases.
CiscoWorks maintains data in the Sybase database,
whereas each NMS maintains its own database. Sync
w/Sybase ensures that device data from the NMS
database is in the Sybase database (Sync w/Platform)
and vice versa. Generally, synchronize the databases
whenever new devices are added to your network. Use
Sync Selected to add individual devices.

Tools>Sybase ESQR Misc>Sybase ESQR Use Sybase ESQR utilities to run and print reports on
any table created with the Device Polling application.

Tools>CW - TACACS
Manager

Administer>Security>CW -
TACACS Manager

Maintain the TACACS password file on UNIX hosts that
act as TACACS servers. Create and update TACACS
accounts and computer-generated passwords.

Tools>CW - Toolbox Misc>CW - Toolbox Allows you to start CiscoWorks applications directly,
without using the menus on your network management
platform. Click on an application’s icon in the Toolbox
window to start the application. You can also display
help for each application from Toolbox.

Glyph Tools>
Workgroup Director

Monitor>Workgroup
Director

Monitors the status of any Cisco concentrator, switch, or
network adapter card.

SunNet Manager
Menu Location

HP OpenView Menu
Location Tasks
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SunNet Manager Post-Installation Tasks
Perform the following tasks before using the CiscoWorks application on SunNet Manager (SNM):

1 Run the SNM Discover tool to create an SNM database and a network map with network devices.
For more information, refer to “Running the SNM Discover Command” later in this chapter. For
detailed information, refer to the SunNet Manager 2.2 User’s Guide.

2 Create other network maps and submaps, and add appropriate devices. Refer to “Adding Cisco
Devices to your SNM Network Map” later in this chapter.

3 Use the SNM Change Type command to change appropriate SNM devices to Cisco devices.
Refer to “Identifying Cisco Devices for CiscoWorks on Your SNM Map” later in this chapter.

4 Use the CiscoWorks Sync w/Sybase application to synchronize the SNM database with the
Sybase database. Refer to “Synchronizing the NMS Database with Sybase” later in this chapter.

5 Check out the expanded CiscoWorks online help. Refer to “CiscoWorks Online Help” earlier in
this chapter.

Before performing any of these tasks, you must become familiar with the SNM Console window and
learn how to access its menu items.

HP OpenView Post-Installation Tasks
Perform the following tasks before using any CiscoWorks application on HP OpenView:

1 Run the HP OpenView Manage Objects command to discover IP devices on your network map.
Refer to “HP OpenView Processes that Affect CiscoWorks” later in this chapter. For detailed
information, refer to the HP OpenView User’s Guide.

2 Create other network maps and submaps, and add the appropriate devices as your needs dictate.
Refer to “Adding Cisco Devices to Your HP OpenView Network Map” later in this chapter.

3 Use the HP OpenView Change Symbol Type command to change appropriate generic devices
to Cisco devices. Refer to “Identifying Cisco Devices for CiscoWorks on HP OpenView” later
in this chapter.

4 Use the CiscoWorks Sync w/Sybase application to synchronize the HP OpenView database with
the Sybase database. Refer to “Synchronizing the NMS Database with Sybase” later in this
chapter.

5 Check out the expanded CiscoWorks online help. Refer to “CiscoWorks Online Help” earlier in
this chapter.

Before performing any of these tasks, you must become familiar with the HP OpenView Console
window and learn how to access its menu items.
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Overview of CiscoWorks on Your Network Management Platform
CiscoWorks is integrated with the SunNet Manager (SNM) or HP OpenView network management
platform.

Note To understand the relationship between your NMS and CiscoWorks, you must become
familiar with certain NMS features. If you use SNM, refer to your SNM documentation for the SNM
Create, Discover, andChange Type commands to ensure your platform is set up properly. If you
use HP OpenView, refer to your HP OpenView documentation for the HP OpenViewOpen/List
Maps, Manage Objects, andChange Symbol Type commands to ensure your platform is set up
properly.

During installation and configuration, CiscoWorks adds customized schema files with Cisco-specific
device types (such as the Cisco AGS+) to the platform’s schema files directory. CiscoWorks also
adds its applications to the NMS menus.

Note Familiarize yourself with the user interface conventions used by Motif or your preferred
windowing system. CiscoWorks supports Motif standards for all its graphical-user-interface
components, such as using the mouse, opening windows and menus, and manipulating windows and
icons. They are not covered within this guide.

It is important to understand the NMS environment and how to use your platform software in
conjunction with CiscoWorks. To answer your NMS network management questions, refer to the
NMS platform documentation.

Getting Started with CiscoWorks on SunNet Manager
The following sections provide detailed information on SNM post-installation tasks and contain an
overview of how CiscoWorks functions on the SNM network management platform.

The following topics are discussed:

• Starting CiscoWorks on SNM

• CiscoWorks Use of SNM Utilities

• SNM Processes that Affect CiscoWorks

• Running the SNM Discover Command

• Adding Cisco Devices to your SNM Network Map

• Identifying Cisco Devices for CiscoWorks on Your SNM Map
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Starting CiscoWorks on SNM
This section briefly explains two ways start the SNM Console to run CiscoWorks. For a more
detailed description and options, refer to theSunNet Manager 2.2 User’s Guide.

You can use several different commands to start the SNM Console. However, you must be running
Open Windows.

Note Do not use the following commands until you install SNM in the default installation
directory.

Starting CiscoWorks without the Database
Perform the following tasks to start CiscoWorks when there is no database present:

Step 1 To start the SNM Console initially or when you want to bring up the last map file, enter the
following:

% snm

If problems occur, your$PATH environment variable might not include a path to SNM
executables. You can enter a fully qualified path. In the following example,/usr/snm/bin is
the path to the executables:

% /usr/snm/bin/snm

If you don’t want to start SNM with a network map, or want to load a specific map with the
start up command, skip to the section, “Starting CiscoWorks with the Database.”

Step 2 SelectFile>Load to load an ASCII-format database map file into the SNM Console.

Starting CiscoWorks with the Database
Select one of the following methods to start CiscoWorks when the database is present:

• To start SNM without a database map file (which clears the run-time database), enter the
following:

% snm -i

• To start SNM with a specified map file (map_name is an ASCII database file), enter the
following:

%snm map_name

Caution The-i option starts the SNM Console and removes the current run-time database. If you
have a run-time database and wish to preserve it, do not use the-i option, or you will lose this data.

For more information on starting the SNM Console or troubleshooting startup problems, refer to the
SunNet Manager 2.2 User’s Guide.
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Opening CiscoWorks Applications from SNM
On the SunNet Manager (SNM) platform, you run CiscoWorks applications either from theTools
menu or the Glyphs menu. Figure6-1 shows CiscoWorks applications available on theTools menu.

Figure 6-1 CiscoWorks Applications on the SunNet Manager Tools Menu

SNM also has a menu that becomes available when you click on an icon. To display the menu, select
an icon, place the pointer anywhere in the window pane, and press the MENU mouse button. On
SNM, icons are calledglyphs, and the menu that becomes available is called theGlyph menu
(Figure 6-2).
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Figure 6-2 CiscoWorks Applications on the Glyph Menu

CiscoWorks Use of SNM Utilities
CiscoWorks uses two SNM utilities: the Results Browser and the Grapher. Following is a brief
description of each and how it is used by CiscoWorks.

• Results Browser—The SNM Results Browser retrieves, organizes, and views network
management data. The Results Browser is used in several CiscoWorks applications, including
Polling Summary.

For example, Polling Summary uses the Results Browser to display query reports on polled
device groups. You can display report data or send this data to the SNM Grapher.

• Grapher—The SNM Grapher presents real-time or logged network data in graphical format. The
Grapher is used by Health Monitor and Real-Time Graphs to display data in graphical format.
You can change the properties of your graph with SNM to reflect your customized colors; delta,
absolute, or cumulative graphing formats; and so on.

For more detailed information on the Results Browser and Grapher, refer to your SNM
documentation.
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SNM Processes that Affect CiscoWorks
Some SNM processes affect how CiscoWorks runs, depending on their configuration in SNM. As
you continue to work with SNM processes and CiscoWorks, consider the following conditions in
which the two environments coexist:

• In SNM, you can customize the operation of the SNM Console and other SNM utilities (such as
the Results Browser and Results Grapher), or you can accept the default configuration. For
example, one option is to specify how device errors are indicated on the screen, either by visual
or audible signals. To set this type of configuration, refer to yourSunNet Manager 2.2 User’s
Guide.

One important option to consider is customizing your system to automatically receive
information about device status. To set this option, open the Console Properties window and
enable the SNM Automatic Management feature, as described in theSunNet Manager 2.2
Reference Guide.

• In SNM, you can use the SNM Discover utility to automatically create your map (referred to by
SNM as arun-time database). You also can manually add devices (referred to by Sun as
components) to your map.

Change Type on theGlyph menu is especially important.Change Type enables you to change
the device type. You may need to use this command if you use the Discover utility, and SNM
incorrectly classifies the element type of a device. You must classify device types accurately
according to their specific product names or product types, because availability and correct
operation of many CiscoWorks applications depends on the correct classification of device type.

• To create a true network map (which includes different hierarchical views, devices, connections,
and buses), refer to theSunNet Manager 2.2 User’s Guide.You also can useCreate or
CiscoWorks Device Management, AutoInstall Manager, or Sync w/Sybase to add new devices
to your network map.

• For a brief overview on how the SNMDiscover command is used, refer to “Running the SNM
Discover Command,” later in this chapter. For a detailed description of Discover, refer to your
SunNet Manager 2.2 Reference Guide.

Running the SNM Discover Command
Most CiscoWorks applications require a database of network devices. They also require a network
map that contains these network devices.

Discover enables you to find the devices in the primary network to which your system is attached.
Use Discover to create a view (map) of your network and a run-time database for SNM. If you did
not install the SNM software in the/usr/snmdirectory, you must set the environment variable for
$SNMHOME as described in theSunNet Manager 2.2 User’s Guide.

Note The amount of time taken byDiscover to find all the devices on your network depends on the
size of your subnet and the number of devices attached to it.

To runDiscover, perform the following steps:

Step 1 Display the SNM Console by entering the following command:

% /usr/snm/bin/snm

The SNM Console window appears.
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Step 2 SelectTools>Discover.

The SNM Discover Program window appears, prompting you to enter the superuser
password.

Step 3 Enter your superuser password.

Discover begins to construct views of the network. WhenDiscover completes the process,
networks appear in the form of cloud glyphs, and devices appear in the form of router
glyphs.

Step 4 To save the database of devices that you created, selectFile>Save.

For detailed information on how to runDiscover, refer to theSunNet Manager 2.2 User’s
Guide. To add devices to your network map after CiscoWorks installation, you can use
Device Management, AutoInstall Manager, or Sync w/Sybase. For more information on
adding devices after a CiscoWorks installation, refer to the CiscoWorks online help
sections on “Device Management,” “AutoInstall Manager,” or “Sync w/Sybase.”

Adding Cisco Devices to your SNM Network Map
To add a Cisco 7000 to your SNM network map, perform the following steps:

Step 1 Display your network map.

Step 2 SelectEdit>Add Object .

You see the Add Object Palette.

Step 3 Click on the Cisco Router icon to display the Symbol Subclasses for Cisco Routers.

Step 4 Using the left mouse button or equivalent, click on the 7000 symbol, then move your mouse
to the network map and click the left mouse button again.

The Cisco 7000 symbol is copied into the map and you see the Add Object window.

Step 5 Fill in the Add Object window, then click onOK  to record information about the object
you just added.

Identifying Cisco Devices for CiscoWorks on Your SNM Map
Network devices located by theDiscover command exist as generic devices. You must identify them
as Cisco devices to take advantage of CiscoWorks functionality.

To change device status from generic to that of a Cisco device, perform the following steps:

Step 1 Use the mouse to point to a Cisco device in the SNM Console window, then press the right
mouse button or equivalent.

The Glyph menu for the device appears, as shown in Figure 6-3.
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Figure 6-3 Glyph Menu

Step 2 SelectChange Type from theGlyph menu. Move the mouse to the right to display the
popup menu, which lists device names and types.

Step 3 Select the device type that matches the one selected in your network map.

For example, if the selected device in your network map is an AGS+, selectCisco-AGS+
from the pull-down menu. The device now appears as a Cisco device.

Step 4 Repeat Steps 1 through 3 to identify other devices in the network map.

Step 5 Confirm that the selected devices have the correct Simple Network Management Protocol
(SNMP) community strings. SelectTools>Propertiesto view the SNM Properties Sheet
window.

Getting Started with CiscoWorks on HP OpenView
The following sections provide detailed information on HP OpenView post-installation tasks and
contain an overview of how CiscoWorks functions on the HP OpenView network management
platform.

The following topics are discussed:

• Starting CiscoWorks on HP OpenView

• Learning about Other CiscoWorks Applications on Your NMS

• CiscoWorks Use of HP OpenView Tools

• HP OpenView Processes that Affect CiscoWorks

• Running the Manage Objects Command on HP OpenView

• Adding Cisco Devices to Your HP OpenView Network Map

• Identifying Cisco Devices for CiscoWorks on HP OpenView

• Synchronizing the NMS Database with Sybase
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Starting CiscoWorks on HP OpenView
This section briefly explains two ways to start the HP OpenView Console to run CiscoWorks. You
can use several different commands to start the HP OpenView Console. However, you must be
running an X window manager, such as Motif.

Note Do not use the following commands until you install HP OpenView in the default installation
directory.

Starting CiscoWorks without the Database
Perform the following tasks to start CiscoWorks when there is no database present:

Step 1 To start the HP OpenView Console initially (when there is no database present) or when
you want to bring up the last map file, enter the following:

% ovw

If problems occur, yourPATH environment variable might not include a path to HP
OpenView executables. You can enter a fully qualified path. In the following example,
/usr/OV/bin is the path to the executables:

% /usr/OV/bin/ovw

If you don’t want to start HP OpenView with a network map, or want to load a specific map
with the startup command, skip to the section, “Starting CiscoWorks with the Database.”

Step 2 SelectFile>Open/List Maps to load a database map file into the HP OpenView Console.

Starting CiscoWorks with the Database
To start CiscoWorks when the database is present, select one of the following methods:

• To start the Console without a database map file (which clears the run-time database), enter the
following:

% ovw -i

Caution The-i option starts the HP OpenView Console and removes the current run-time database.
If you have a run-time database and wish to preserve it, do not use the-i option, or you will lose this
data.

• To start the Console with a specified map file (map_name is an ASCII database file), enter the
following:

% ovw - map map_name

For more information on starting the HP OpenView Console or troubleshooting startup problems,
refer to theHP OpenView 3.3 User’s Guide.
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Opening CiscoWorks Applications from HP OpenView
CiscoWorks is fully integrated with HP OpenView, so you can access CiscoWorks applications
directly from the main window of the HP OpenView platform. (See Figure 6-4.)

Figure 6-4 HP OpenView Main Window

CiscoWorks applications are available from HP OpenView main menus. For example, to open the
Process Manager application, selectAdminister>CW - System>CW - Process Mgr.

Running Device-Dependent CiscoWorks Applications on HP OpenView
HP OpenView does not use glyphs or aGlyph menu. To access device-dependent applications,
perform the following steps:

Step 1 Select a device in your network map or submap.

Step 2 Select the specified CiscoWorks application from the appropriate menu.

Learning about Other CiscoWorks Applications on Your NMS
This section briefly outlines the steps you must complete on your NMS before continuing with
CiscoWorks tasks. For instructions on using specific CiscoWorks applications, refer to the
appropriate sections in this section or to the CiscoWorks online help system.
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Follow these steps to learn about CiscoWorks applications that use the Sybase database:

Step 1 Start SunNet Manager or HP OpenView.

Refer to the sections “Starting CiscoWorks on SNM” or “Starting CiscoWorks on HP
OpenView” earlier in this chapter to learn how to start your network management station
(NMS).

Step 2 Access Security Manager to turn on authentication checking and provide users and groups
access privileges to CiscoWorks applications.

For more information, refer to the CiscoWorks online help section on setting up domains
and securing applications in Security Manager.

Step 3 Set up your NMS database using the utilities provided with your NMS software.

For SNM Discover information, refer to “Running the SNM Discover Command” or to the
SNM documentation. For information on the HP OpenViewManage Objectscommand,
refer to “HP OpenView Processes that Affect CiscoWorks” or to the HP OpenView
documentation.

Step 4 Use Sync w/Sybase to synchronize your NMS database devices with the CiscoWorks
Sybase database.

If you are adding individual devices, use Device Management, AutoInstall Manager, or
Sync w/Sybase to add device data to the Sybase database. For information on AutoInstall
Manager, Sync w/Sybase and Device Management, refer to the appropriate CiscoWorks
online help sections.

Note Sync w/Sybase synchronizes, or adds, devices in your NMS database to the CiscoWorks
database.Sync w/NMS, located within Sync w/Sybase, allows you to add devices from the
CiscoWorks database to the NMS database. Alternatively, you can manually add devices created in
CiscoWorks by usingCreate in HP OpenView orInitialize  in Device Management.

Step 5 Use the CiscoWorks applications and NMS utilities to help you monitor and manage your
network activity.

Table 6-2 lists general network management tasks and their responsible software
applications. Use this table to determine which documentation set (CiscoWorks or your
NMS) to use if you have questions or need information. TheX indicates that this
information is located in the NMS manual set for the utility or application.

Table 6-2 CiscoWorks Versus HP OpenView Task Descriptions

Task NMS Software CiscoWorks Software

Start NMS software X

UseCreate or Manage Objects X

Traverse your network map (NMS database) X

Create or find devices or device properties X AutoInstall Manager,
Device Mgmt, and Sync
w/Sybase

Modify or change device or device properties X Device Mgmt, Sync
w/Sybase
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CiscoWorks Use of HP OpenView Tools
CiscoWorks uses one HP OpenView application,xnmgraph, which presents real-time or logged
network data in graphical format. Thexnmgraph application is used in the Health Monitor and
Real-Time Graphs applications to display data in graphical format. You can change the graph
properties either with the popup menu on the graph window or by editing the X resources in the
/usr/OV/appdefaults/xnmfile.

For more detailed information onxnmgraph, refer to your HP OpenView documentation.

HP OpenView Processes that Affect CiscoWorks
Some HP OpenView processes affect how CiscoWorks runs, depending on their configuration in
OpenView. As you continue to work with OpenView processes and CiscoWorks, consider the
following conditions in which the two environments coexist:

• In HP OpenView, you can customize the operation of the HP OpenView Console and other HP
OpenView tools.

• In HP OpenView, an IP Internet map is automatically created for you, providing data on all IP
devices connected to your NMS system. To automatically discover newly added or modified IP
devices, useManage Objects. You can also manually add devices (referred to by HP OpenView
asobjects) to your map.

Change Symbol Type on the HP OpenView symbol popup menu is especially inportant.
Change Symbol Type enables you to change device symbol types. You may need to use this
command if you usedManage Objects, and HP OpenView assigns an incorrect symbol to the
device. You must classify device types accurately according to their specific product names or
product types, because availability and correct operation of many CiscoWorks applications
depends on the correct classification of the device type.

• To create a true network map (which includes different submaps, devices, connections, and
buses), refer to theHP OpenView User’s Guide.You also can useNew Map, or the CiscoWorks
Device Management, AutoInstall Manager, or Sync w/Sybase to add new devices to your
network map.

Move or connect devices X

Copy or delete devices X Device Mgmt, Domain
Manager

Save your network map (run-time database) X

Modify a graph display X

Print graphs, windows, or text files X

Change the symbol type X

Check the cause of an event X

Change how symbol type changes propagate X

View or change the status of requests X

View error and traps X

Manage SNMP devices X All CiscoWorks
applications

Task NMS Software CiscoWorks Software
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Running the Manage Objects Command on HP OpenView
CiscoWorks applications require a database of network devices and a network map that contains
these devices. HP OpenView automatically displays a default map, called IP Map, which shows all
the IP devices connected to the local HP OpenView system. TheManage Objects command enables
you to find the devices in the primary network to which your system is attached. UseManage
Objects to view your network and a run-time database for HP OpenView.

Note The amount of timeManage Objects takes to find devices on your network depends on the
size of your subnet and the number of devices attached to it.

To runManage Objects, perform the following steps:

Step 1 Display the HP OpenView Console by entering the following command:

% ovw

The HP OpenView Console window appears.

Step 2 Click on the IP Internet default map to topen it.

Step 3 Click on a device symbol to select it.

Step 4 SelectOptions>Manage Objects.

Manage Objects begins to construct views of the network. WhenManage Objects
completes the process, you see a representation of the subnetwork joined to the selected
device. Subnetworks appear in the form of lines connecting the selected device symbol to
other device symbols.

Step 5 SelectFile>Save Map Asto save the database of devices that you created.

For detailed information on how to runManage Objects, refer to theHP OpenView User’s
Guide. To add devices to a network map after CiscoWorks installation, you can use the
Device Management, AutoInstall Manager, or Sync w/Sybase applications. For more
information on adding devices after CiscoWorks installation, refer to “Adding Cisco
Devices to Your HP OpenView Network Map.”

Adding Cisco Devices to Your HP OpenView Network Map
To add a Cisco device to your new network map, perform the following steps:

Step 1 Display your network map.

Refer to your HP OpenView documentation for instructions on how to use your network
map.

Step 2 SelectEdit>Add Object .

The Add Object Palette appears.

Step 3 Click on the Cisco Router icon to display the Symbol Subclasses for Cisco Routers.

Step 4 Using the left mouse button or equivalent, click on a Cisco device symbol, then move your
mouse to the network map and click the left mouse button again.

The Cisco device symbol is copied into the map and the Add Object window appears.
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Step 5 Complete the Add Object window, then click onOK  to record information about the object
you just added.

Identifying Cisco Devices for CiscoWorks on HP OpenView
Network devices that are discovered byManage Objects may exist as generic devices. You must
identify them as Cisco devices to take advantage of CiscoWorks functionality.

To useChange Symbol Type to change device status from generic to that of a Cisco device, perform
the following steps:

Step 1 Use the mouse to point to a Cisco device in the HP OpenView Console window.

Step 2 Press the right mouse button or equivalent.

The symbol popup menu for the device appears, as shown in Figure 6-5.

Figure 6-5 Symbol Popup Menu

Step 3 SelectChange Symbol Type from theSymbol Popup menu.

The Change Symbol Type window appears, as shown in Figure 6-6.
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Figure 6-6 Change Symbol Type

Step 4 Select a symbol class that corresponds to the device selected in the map. For example, if
the selected device in your network map is a Cisco 7000, select Cisco Router (because
Cisco 7000 is a class of Cisco Router).

The Change Symbol Type window expands to show you the Symbol Subclasses for Class
Cisco Router.

Step 5 Select a symbol subclass for the specified symbol. For example, if the selected device in
your network map is a Cisco 7000, select the 7000 symbol.

Step 6 Repeat Steps 1 through 5 to identify other devices in the network map.

Step 7 Confirm that the selected devices have the correct SNMP community strings by viewing
the SNMP Configuration window. SelectOptions>SNMP Configuration from the HP
OpenView menu bar.

Synchronizing the NMS Database with Sybase
CiscoWorks uses two separate databases:

• The NMS database, ornms, stores information about Cisco network devices, configuration
details, and other data needed by each application. This is the database that Sync w/Sybase uses.

• The polling database, orpolldb, stores dynamic polling information from your Cisco devices.
The information stored in this database is deleted frequently based on the thresholds you set up
during installation.

The NMS run-time database is a third database that interacts with the CiscoWorks databases. This
platform database stores information about the network. By synchronizing the Sybase database with
the NMS database of the network platform, you build a complete resource of information.
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Your NMS platform maintains a run-time database of devices that you create using NMS utilities.
In order to use CiscoWorks applications, you must list devices in the Sybase database. Sync
w/Sybase performs the following functions to enable you to use CiscoWorks applications:

• Adds entries for your network devices to the NMS database.

• On SunNet Manager (SNM), it turns on the Cisco agent in the Properties sheet for Cisco devices.

• Confirms that the device lists in the NMS platform and Sybase databases match one another.

Use Sync w/Sybase to synchronize database information. The Syncw/Sybase application appears in
the CiscoWorks menu and device popup menus. Run Sync w/Sybase if you just initialized your
NMS and want to fully synchronize both databases. Run Sync w/Sybase from the device menu if
you want to synchronize one or more specific devices. In both cases, the Sync w/Sybase window,
from which you can select other options, displays. (See Figure 6-7.)

Figure 6-7 Sync w/Sybase

Depending on the number of database records and the information contained in each, database
synchronization can be timely.

Timesaver First-time CiscoWorks users should run the Device (Network>Sybase) option to
synchronize all device information. If you are a first-time user and want the quickest method of
synchronizing, useQuick Sync, which synchronizes all the devices, with the warning that device
information will not be complete. If you useQuick Sync, you may want to return to Sync w/Sybase
when you have more time to use the Device (Network>Sybase) option to fill in the incomplete
device information.

To adjust for synchronization time and to meet special needs, select one of the following commands
from theOptions menu of the Sync w/Sybase window:

• Devices (Network—>Sybase)

Copies the complete number and contents of database records from your NMS database to
Sybase. These records might include information about the hardware platforms, community
strings, and so forth. Allows you to choose the NMS device records that you want to add to
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Sybase. To select contiguous items, hold down theShift key and click on additional device
names, or drag through a range of names. To select discontiguous items, hold down theControl
key and select individual device names. With the device name(s) selected, click onSync.

• Domains (Network—>Sybase)

Updates device records for the selected domain in the Sybase database. With the domain name
selected, click onSync.

• Quick Sync (NMS—>Sybase)

Creates entries in the Sybase table only for devices listed in your NMS—but excludes specific
information such as inventory details or hardware platforms. Use this command if you need the
databases to quickly recognize the devices contained in each. Later, if you decide that you want
the complete device information available from your NMS platform, you can copy it with
another command from theOptions menu of Sync w/Sybase, or enter the information via the
CiscoWorks Device Management application.

• Sybase—>NMS

Copies only the Sybase device records that did not yet exist in HP OpenView into the HP
OpenView database. This is the inverse process ofDevices (Network—>Sybase). When you use
Device Management or AutoInstall Manager to add a device to Sybase, the device name is not
recognized by HP OpenView until you useSybase—>NMS. Nor is the device name recognized
if you add it to Sybase but do not add the symbol to HP OpenView. If you delete a device from
HP OpenView, however, it remains as a record in Sybase until you manually delete it. A network
symbol (circle) appears in your network map that lists the device records added from this process.

• Timeout Interval

Displays a dialog box where you can specify how much time can elapse before synchronization
terminates and declares the device unreachable. You can also specify the default timeout using
the X Resource timeout Interval in your .Xdefaults file. The resource name is synchTimeout.

Figure 6-8 illustrates the relationship between the HP OpenView and CiscoWorks databases.
Although you can directly add device names to either database, you must run Sync w/Sybase to
confirm that the information about a particular device is correct in both places.

Figure 6-8 Database Creation for your NMS platform and CiscoWorks

For more detailed information about the database and the Sync w/Sybase and Sync with NMS
applications, refer to the CiscoWorks online help on “Sync w/Sybase.” For more information about
the AutoInstall Manager application, refer to the CiscoWorks online help on “AutoInstall Manager.”
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After you finish creating a run-time database with network devices, follow these steps to run the
Sync w/Sybase application:

Step 1 SelectMisc>Sync w/Sybase.

The Sync w/Sybase window appears. (See Figure 6-9.)

Figure 6-9 Sync w/Sybase Window

The synchronization process takes from 3 minutes to over an hour, depending on the size
of your network and the number of devices you are synchronizing.

Select File>Exit to stop the synchronization process at any time. The devices synchronized
up to this point are saved in the Sybase database.

Step 2 SelectFile>Exit  to exit this window.

Setting Environment Variables
To use your NMS and CiscoWorks, you must make sure that the environment variables explained in
Table 5-1, “Environment Variables and Directory Paths,” are set correctly. Refer to “Verifying
Changes to the .cshrc File” in the “Validating CiscoWorks Installation” chapter.

Normally, these environment variables are set during the CiscoWorks installation process.

Quick Tutorial on Using a CiscoWorks Application
This section provides a general idea of how to use a CiscoWorks application. It uses the Path Tool
application as an example. For a detailed explanation of all CiscoWorks applications, refer to the
CiscoWorks online help.

To use the Path Tool application, you must have at least two network devices in the Sybase database.
Use Sync w/Sybase to add network devices to the Sybase database.
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Displaying the Path between Two Devices
The Path Tool application enables you to display the routing path between a source device and a
destination device.

To graphically display the path between two devices, perform the following steps:

Step 1 On SunOS:

In the SNM Console window, click on an SNMP device and then display theGlyph menu.
Next, selectTools>Path Tool from theGlyph menu.

On HP-UX:

In the HP OpenView Console window, click on an SNMP device and select
Diagnose>Network Connectivity>CW - Path Tool.

A window similar to that in Figure6-10 appears. The information about the source device
is completed.

Figure 6-10 Path Tool Window

Step 2 To select the destination device, click onSelect next to the Path Destination field or enter
the complete device name in the Path Destination field.

If you click onSelect, the Device Selection window appears listing the devices in the SNM
database. It is similar to the window shown in Figure 6-11.
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Figure 6-11 Device Selection Window

Step 3 Click on the device that you want to specify as the destination and click onOK .

After the connection has been established, the device name appears in the Path Destination
field in the Path Tool window.

Step 4 Click onOK  in the Path Tool window to display the Path Tool Hops window.

A browser window then appears (similar to the window shown in Figure6-12), displaying
the progress of the Path Tool as it makes each network hop from the source to the
destination device.
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Figure 6-12 Path Tool Window with Text

After the connection is established, another Path Tool window appears (similar to the window shown
in Figure 6-13), graphically displaying the path between the source and destination devices you
specified.

Figure 6-13 Path Tool Window with a Graphic Display

Step 5 Select File>Exit to close the window.

For more information on how to use the Path Tool, refer to the online help for Path Tool.
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Security Options
If you use the Security Manager application to protect specific applications, all users must enter a
valid username and password to access applications. For a detailed description of which CiscoWorks
applications you can protect, refer to the CiscoWorks online help section on setting up domains and
securing applications.

Each CiscoWorks application has varying levels of access privileges. Users are granted inherent
privileges to certain applications (such as the ability to display devices) based solely on their
group-domain associations. The CiscoWorks administrator governing Security Manager can grant
further levels of “application-specific” privileges (such as add or change database information) to
selected groups.

CiscoWorks Login and Logout Functions
When security is enabled, if you previously usedLogin to log into CiscoWorks, no user
identification window appears. If you do not useLogin, each time you run a secured application,
CiscoWorks prompts you for a username and password. This login controls access to the application.

If you use Security Manager to secure your CiscoWorks applications, you can useLogin and
Logout. For more information on logging in and out, refer to the CiscoWorks online help section on
Login andLogout.

Timesaver By using Login, you need log in only once. If you do not useLogin, CiscoWorks
requires user identification information (username and password) each time you attempt to start a
secured application.
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