![]() ![]() ![]() ![]() ![]() ![]() ![]() ![]() ![]() |
This chapter describes how to configure a Cisco 1600 series router to dial into a central-site router over an Integrated Services Digital Network (ISDN) line and provides verification steps and troubleshooting tips.
This chapter contains the following sections:
The configurations in this chapter are based on the following assumptions:
Before you begin configuration, be aware of the following:
This section describes how to configure your Cisco 1600 for Internet Protocol (IP) when dialing out over an ISDN line. You should configure your router for IP if you want to use Internet services, such as the World Wide Web, or if the network that you are dialing into uses IP.
These are the major tasks when configuring your router:
Figure 3-1 illustrates the example configuration used in this section.
Use this table to configure the router for some global parameters, including the ISDN switch type that the router is connected to through the ISDN line, and how log and debug messages are timestamped.
Use this table to configure the router with some security measures, including the password used to access the router and the username and password used for Challenge Handshake Authentication Protocol (CHAP) and Password Authentication Protocol (PAP) authentication with the central-site router.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Specify a password to prevent unauthorized access to the router. | Router(config)#
| enable password 1600user | ||
| Configure the router with a host name, which is used in prompts and default configuration file names.
For PPP authentication, the host name entered with this command must match the username of the central-site router. | Router(config)#
| hostname 1600 | ||
| Specify the password used during caller identification and CHAP and PAP authentication.
For CHAP and PAP authentication, the username entered with this command must match the host name of the central-site router. | 1600(config)#
| username HQ password guessme |
Use this table to configure the Ethernet interface (which connects the router to your local network) with an IP address. This gives your router a unique address on your local network.
Step | Task | Router Prompt | Command | ||
| Enter configuration mode for the Ethernet interface. | 1600(config)#
| interface Ethernet0 | ||
| Configure this interface with an IP address and a subnet mask. | 1600(config-if)#
| ip address 172.16.25.42 255.255.255.224 | ||
| Enable the interface and the configuration changes you have just made on the interface. | 1600(config-if)#
| no shutdown | ||
| Exit configuration mode for this interface. | 1600(config-if)#
| exit |
You can verify your configuration by checking that the Ethernet interface has the correct IP address:
Step 1 From the privileged EXEC command mode, enter the show arp command:
Step 2 You should see command output similar to the following:
Step 3 The IP address (shown in bold in the example) should be your router Ethernet IP address and should match the IP address that you entered with the ip address command.
Step 4 To continue configuration, re-enter global configuration mode.
Use this table to configure the ISDN interface (which connects the router to the WAN) for the following:
Step | Task | Router Prompt | Command | ||
| Enter configuration mode for the ISDN interface. | 1600(config)#
| interface BRI0 | ||
| Add a description of this interface to help you remember what is attached to the interface. | 1600(config-if)#
| description ISDN connectivity | ||
| Define the service profile identifier (SPID) number assigned by the ISDN service provider to the B1 channel.
This step is required only when the service provider has assigned a SPID to your ISDN line. Not all ISDN lines have SPIDs. | 1600(config)#
| isdn spid1 555987601 | ||
| Define the SPID number assigned by the ISDN service provider to the B2 channel.
This step is required only when the service provider has assigned a SPID to your ISDN line. Not all ISDN lines have SPIDs. | 1600(config)#
| isdn spid2 555987602 | ||
| Enable IP routing on this interface without assigning an IP address. | 1600(config-if)#
| ip unnumbered Ethernet0 | ||
| Configure this interface to place a call to multiple sites and to authenticate calls from multiple sites based on IP address and dialer string (phone number).
The name you enter after the name keyword in this command must match the name entered with the username command in the previous "Configuring Security" section. | 1600(config-if)#
| dialer map ip 192.168.37.40 name HQ 5552053 | ||
| Configure bandwidth on demand by setting the maximum load before the router places another call to a destination. | 1600(config-if)#
| dialer load-threshold 70 | ||
| Assign the dialer interface to a dialer group. | 1600(config-if)#
| dialer-group 1 | ||
| Set the encapsulation method on this interface to PPP. | 1600(config-if)#
| encapsulation ppp | ||
| Enable CHAP and PAP authentication on this interface. CHAP authentication is attempted first. If the central-site router does not support CHAP, PAP is used for authentication. | 1600(config-if)#
| ppp authentication chap pap callin | ||
| Enable multilink PPP on this interface. | 1600(config-if)#
| ppp multilink | ||
| Enable the interface and the configuration changes you have just made on the interface. | 1600(config-if)#
| no shutdown | ||
| Exit configuration mode for this interface. | 1600(config-if)#
| exit |
You can verify your configuration to this point by confirming the ISDN line status:
Step 1 From the privileged EXEC command mode, enter the show isdn status command.
Step 2 You should see command output similar to the following:
show isdn status
The current ISDN Switchtype = basic-5ess
ACTIVE
State = MULTIPLE_FRAME_ESTABLISHED
Step 3 Confirm that the current ISDN switch type (shown in bold in the example) matches the actual switch type that you are using.
Step 4 Confirm that the "Layer 1 status: ACTIVE" message (shown in bold in the example) appears in the command output.
Step 5 Confirm that the "State = MULTIPLE_FRAME_ESTABLISHED" message (shown in bold in the example) appears in the command output.
Step 6 To continue configuration, re-enter global configuration mode.
If you are still having problems, do the following:
Use this table to configure some parameters that control how and when the router dials the central-site router, including:
Step | Task | Router Prompt | Command | ||
| Establish a static IP route to the remote network. | 1600(config)#
| ip route 0.0.0.0 0.0.0.0 192.168.37.40 | ||
| Establish a static IP route to the central-site router through this interface. | 1600(config)#
| ip route 192.168.37.40 255.255.255.255 BRI0 | ||
| Define a standard access list based on Internet Control Message Protocol (ICMP) traffic. | 1600(config)#
| access-list 101 permit icmp any any | ||
| Define a standard access list based on IP traffic. | 1600(config)#
| access-list 101 permit ip any any | ||
| Specify an dialer list by list number and protocol (IP) to define the "interesting" packets that can trigger a call to the destination. | 1600(config)#
| dialer-list 1 protocol ip list 101 |
You can verify your configuration to this point by:
You can verify your configuration by confirming the static IP route:
Step 1 From the privileged EXEC command mode, enter the show ip route command.
Substitute the IP address of the central-site router ISDN interface for the IP address shown in the example.
Step 2 Confirm that the "directly connected via BRI" message (shown in bold in the example) appears in the command output:
* directly connected, via BRI0
Step 3 To continue configuration, re-enter global configuration mode.
You can verify your configuration by confirming connectivity to the central-site router:
Step 1 From the privileged EXEC command mode, enter the ping command followed by the IP address of the central-site router:
192.168.37.40
Success rate is 80 percent (4/5)
, round-trip min/avg/max = 40/43/48 ms
Step 2 Note the percentage in the "Success rate..." line (shown in bold in the example). If the success rate is 60 percent (3/5) or greater, your router is successfully transferring data to the central-site router.
Step 3 To continue configuration, re-enter global configuration mode.
Step 1 From the privileged EXEC mode, confirm that the ISDN is connected to the remote site by entering the ping command followed by the IP address of the central-site router:
192.168.37.40
Step 2 Enter the show ppp multilink command.
Step 3 Confirm that the "Master link is Virtual-Access1" message (shown in bold in the example) appears in the command output.
show ppp multilink
Master link is Virtual-Access1
Step 4 If you do not see the message in the output, take one or both of the following steps:
Step 5 To continue configuration, re-enter global configuration mode.
Step 1 From the privileged EXEC command mode, confirm that the ISDN line is connected to the remote site by entering the ping command followed by the IP address of the central-site router:
ping 192.168.37.40
Step 2 Enter the show interface virtual-access 1 command.
Step 3 Confirm that the "Open: IPCP" message (shown in bold in the example) appears in the command output:
Open: IPCP
Step 4 To continue configuration, re-enter global configuration mode.
Step 1 From the privileged EXEC command mode, confirm that the ISDN line is connected to the remote site by entering the ping command followed by the IP address of the central-site router:
192.168.37.40
Step 2 Create enough network traffic so that the second ISDN B channel dials the remote site.
Step 3 Check the LEDs labeled B1 and B2.
If both LEDs are lit solid, multilink PPP is correctly configured for both ISDN B channels.
Step 4 To continue configuration, re-enter global configuration mode.
If you are still having problems, do the following:
Use this table to configure some parameters that control access to the router, including the type of terminal line used with the router, how long the router waits for a user entry before it times out, and the password used to start a terminal session with the router.
Step | Task | Router Prompt | Command | ||
| Specify the console terminal line. | 1600(config)#
| line console 0 | ||
| Set the interval that the EXEC command interpreter waits until user input is detected. | 1600(config-line)#
| exec-timeout 5 | ||
| Specify a virtual terminal for remote console access | 1600(config-line)#
| line vty 0 4 | ||
| Specify a password on the line. | 1600(config-line)#
| password lineaccess | ||
| Enable password checking at terminal session login. | 1600(config-line)#
| login | ||
| Exit configuration mode. | 1600(config-line)#
| end |
If you are having problems or the output that you received during the verification steps is very different from what is shown, you can troubleshoot your router with the Cisco IOS debug commands. The debug commands provide extensive command output that is not included in this document.
![]() | Caution If you are not familiar with Cisco IOS debug commands, you should read the "Using Debug Commands" section in the "Cisco IOS Basic Skills" chapter before attempting any debugging. |
Following are debug commands that are helpful when troubleshooting ISDN with IP routing. Follow these commands with the ping command to begin debug output:
This section describes a configuration for Internet Packet Exchange (IPX) protocol when dialing out over an ISDN line. You should configure your router for IPX if the network that you are dialing into uses IPX and you want to access the IPX services, such as file servers and printer servers, that are available on that network.
These are the major tasks when configuring your router:
Figure 3-2 illustrates the example configuration used in this section.
Use this table to configure the router for some global parameters, including the ISDN switch type that the router is connected to through the ISDN line, and how log and debug messages are timestamped.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Enter configuration mode. | Router# | configure terminal | ||
| Configure the router to show the date and time of all debug messages.
This command is optional, but recommended if you use debug commands to troubleshoot your configuration. | Router(config)#
| service timestamps debug datetime msec | ||
| Configure the router to show the date and time of all log messages.
This command is optional, but recommended if you use the verification steps described in this guide. This feature is enabled for all the example command output shown in this guide. | Router(config)#
| service timestamps log datetime msec | ||
| Configure the type of central office switch being used on the ISDN interface. Use the keyword that matches the ISDN switch type that you are using:
|
Router | isdn switch-type basic-ni1 |
Use this table to configure the router with some security measures, including the password used to access the router and the username and password used for Challenge Handshake Authentication Protocol (CHAP) and Password Authentication Protocol (PAP) authentication with central-site routers.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Specify a password to prevent unauthorized access to the router. | Router(config)#
| enable password 1600user | ||
| Configure the router with a host name, which is used in prompts and default configuration file names.
For PPP authentication, the host name entered with this command must match the username of the central-site router. | Router(config)#
| hostname 1600 | ||
| Specify the password used during caller identification and CHAP and PAP authentication.
For CHAP and PAP authentication, the username entered with this command must match the host name of the central-site router. | 1600(config)#
| username HQ password guessme |
Use this table to enable IPX routing on the router. The default setting for the router is IPX routing disabled.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Enable IPX routing and configure the router with its IPX address. | 1600(config)#
| ipx routing 0060.834f.66dd |
Use this table to configure the Ethernet interface (which connects the router to your local network) with an IPX address. Doing so gives your router a unique address on your local network.
Step | Task | Router Prompt | Command | ||
| Enter configuration mode for the Ethernet interface. | 1600(config)#
| interface Ethernet0 | ||
| Enable IPX routing on this interface. | 1600(config-if)#
| ipx network ABC | ||
| Enable the interface and the configuration changes you have just made on the interface. | 1600(config-if)#
| no shutdown | ||
| Exit configuration mode for the interface. | 1600(config-if)#
| exit |
Use this table to configure the ISDN interface (which connects the router to the WAN) for the following:
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Enter configuration mode for the ISDN interface. | 1600(config)#
| interface BRI0 | ||
| Add a description of this interface to help you remember what is attached to the interface. | 1600(config-if)#
| description ISDN connectivity | ||
| Define the service profile identifier (SPID) number assigned by the ISDN service provider to the B1 channel.
This step is required only when the service provider has assigned a SPID to your ISDN line. Not all ISDN lines have SPIDs. | 1600(config)#
| isdn spid1 555987601 | ||
| Define the SPID number assigned by the ISDN service provider to the B2 channel.
This step is required only when the service provider has assigned a SPID to your ISDN line. Not all ISDN lines have SPIDs. | 1600(config)#
| isdn spid2 555987602 | ||
| Enable IPX routing on this interface. | 1600(config-if)#
| ipx network 123 | ||
| Disable IPX fast switching on this interface. | 1600(config-if)#
| no ipx route-cache | ||
| Set the router to respond to a local server watchdog packets on behalf of a remote client (called spoofing). | 1600(config-if)#
| ipx watchdog-spoof | ||
| Configure this interface to place a call to multiple sites and to authenticate calls from multiple sites based on IPX address and dialer string (phone number).
The value 123 represents the IPX network number of the ISDN network. The value 0000.0c03.ecc6 represents the IPX address of the central-site router. The name you enter after the name keyword in this command must match the name entered with the username command in the previous "Configuring Security" section. | 1600(config-if)#
| dialer map ipx 123.0000.0003.eccb name HQ broadcast 5552053 | ||
| Assign the dialer interface to a dialer group. | 1600(config-if)#
| dialer-group 1 | ||
| Disable weighted fair queueing for this interface. | 1600(config-if)#
| no fair-queue | ||
| Set the encapsulation method on this interface to PPP. | 1600(config-if)#
| encapsulation ppp | ||
| Enable CHAP and PAP authentication on this interface. CHAP authentication is attempted first. If the central-site router does not support CHAP, PAP is used for authentication. | 1600(config-if)#
| ppp authentication chap pap callin | ||
| Enable multilink PPP on this interface. | 1600(config-if)#
| ppp multilink | ||
| Enable the interface and the configuration changes you have just made on the interface. | 1600(config-if)#
| no shutdown | ||
| Exit configuration mode for the BRI interface. | 1600(config-if)#
| exit |
You can verify your configuration to this point by
Step 1 From the privileged EXEC command mode, enter the show isdn status command.
Step 2 You should see command output similar to the following:
show isdn status
The current ISDN Switchtype = basic-5ess
ACTIVE
State = MULTIPLE_FRAME_ESTABLISHED
Step 3 Confirm that the current ISDN switch type (shown in bold in the example) matches the actual switch type that you are using.
Step 4 Confirm that the "Layer 1 status: ACTIVE" message (shown in bold in the example) appears in the command output.
Step 5 Confirm that the "State = MULTIPLE_FRAME_ESTABLISHED" message (shown in bold in the example) appears in the command output.
Step 6 To continue configuration, re-enter global configuration mode.
If you are still having problems do the following:
Step 1 From the privileged EXEC command mode, enter the show ipx route command:
123
(PPP), BR0
Step 2 Confirm that the IPX network number (shown in bold in the example) matches the IPX network number that you configured with the ipx network command when you configured the Ethernet interface.
Step 3 To continue configuration, re-enter global configuration mode.
Step 1 From the privileged EXEC command mode, enter the show ppp multilink command.
Step 2 Confirm that the "Master link is Virtual-Access1" message (shown in bold in the example) appears in the command output
Master link is Virtual-Access1
Step 3 To continue configuration, re-enter global configuration mode.
Use this table to configure some parameters that control how and when the router dials the central-site router, including:
Step | Task | Router Prompt | Command | ||
| Define a standard access list based on IPX network variables. | 1600(config)#
| access-list 900 deny any any all any 457 | ||
| Define a standard access list based on IPX network variables. | 1600(config)#
| access-list 900 deny rip any rip any rip | ||
| Define a standard access list based on IPX network variables. | 1600(config)#
| access-list 900 deny sap any sap any sap | ||
| Define a standard access list based on IPX network variables. | 1600(config)#
| access-list 900 permit any any all any all | ||
| Specify an access list by list number and protocol (IPX) to define the "interesting" packets that can trigger a called to the destination. | 1600(config)#
| dialer-list 1 protocol ipx list 900 |
You can verify your configuration to this point by
Step 1 From the privileged EXEC command mode, enter the ping command. The output should be similar to the following:
123.0000.0c03.ecc6
Success rate is 80 percent (4/5)
, round-trip min/avg/max = 44/44/44 ms
Step 2 Verify the following in the command output:
Step 3 To continue configuration, re-enter global configuration mode.
Step 1 From the privileged EXEC command mode, enter the ping command:
123.0000.0c03.ecc6
Step 1 Enter the show interface command:
Open: IPXCP
Step 2 Confirm that the "Open: IPXCP" message (shown in bold in the example) appears in the command output.
Step 3 To continue configuration, re-enter global configuration mode.
Use this table to configure some parameters that control access to the router, including the type of terminal line used with the router, how long the router waits for a user entry before it times out, and the password used to start a terminal session with the router.
Step | Task | Router Prompt | Command | ||
| Specify the console terminal line. | 1600(config)#
| line console 0 | ||
| Set the interval that the EXEC command interpreter waits until user input is detected. | 1600(config-line)#
| exec-timeout 5 | ||
| Specify a virtual terminal for remote console access | 1600(config-line)#
| line vty 0 4 | ||
| Specify a password on the line. | 1600(config-line)#
| password lineaccess | ||
| Enable password checking at terminal session login. | 1600(config-line)#
| login | ||
| Exit configuration mode. | 1600(config-line)#
| end |
If you are having problems or the output that you received during the verification steps is very different from what is shown, you can troubleshoot your router with the Cisco IOS debug commands. The debug commands provide extensive command output that is not included in this document.
![]() | Caution If you are not familiar with Cisco IOS debug commands, you should read the "Using Debug Commands" section in the "Cisco IOS Basic Skills" chapter before attempting any debugging. |
Following are debug commands that are helpful when troubleshooting ISDN with IPX routing. Follow these commands with the ping command to begin debug output:
This section describes how to configure the router so that it uses the ISDN line as a leased line connection to the central-site router. In the previous configurations in this chapter, the ISDN line functions as a switched connection to the central-site router. It only dials the central-site router when it detects specified types and amounts of data traffic. In a leased line configuration, the ISDN line is always active and connected to the central office switch.
In addition to the assumptions described in the "Before You Begin" section at the beginning of this chapter, this configuration is based on the additional assumption that both ISDN B channels are connecting to the same central-site router.
This configuration describes how to configure the router for IP and IPX. If you followed the configuration instructions for IP and IPX in the previous sections of this chapter, you might not have to do all of the steps shown in this section.
These are major tasks when configuring your router:
Figure 3-3 illustrates the example configuration that is used in this section.
Use this table to configure the router for some global parameters, including the ISDN switch type that the router is connected to through the ISDN line, and how log and debug messages are timestamped.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Enter configuration mode. | Router# | configure terminal | ||
| Configure the router to show the date and time of all debug messages.
This command is optional, but recommended if you use debug commands to troubleshoot your configuration. | Router(config)#
| service timestamps debug datetime msec | ||
| Configure the router to show the date and time of all log messages.
This command is optional, but recommended if you use the verification steps described in this guide. This feature is enabled for all the example command output shown in this guide. | Router(config)#
| service timestamps log datetime msec | ||
| Configure the type of central office switch being used on the ISDN interface. Use the keyword that matches the ISDN switch type that you are using:
|
Router | isdn switch-type basic-ni1 |
Use this table to configure the router with some security measures, including the password used to access the router and the username and password used for Challenge Handshake Authentication Protocol (CHAP) and Password Authentication Protocol (PAP) authentication with the central-site router.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Specify a password to prevent unauthorized access to the router. | Router(config)#
| enable password 1600user | ||
| Configure the router with a host name, which is used in prompts and default configuration file names.
For PPP authentication, the host name entered with this command must match the username of the central-site router. | Router(config)#
| hostname 1600 | ||
| Specify the password used during caller identification and CHAP and PAP authentication.
For CHAP and PAP authentication, the username entered with this command must match the host name of the central-site router. | 1600(config)#
| username HQ password guessme |
Use this table to enable IPX routing on the router. The default setting for the router is IPX routing disabled.
Step | Task | Router Prompt | Command | ||
| Enable IPX routing and configure the router with an IPX address. | 1600(config)#
| ipx routing 0060.834f.66dd |
Use this table to set up the ISDN line for a leased line configuration.
Step | Task | Router Prompt | Command | ||
| Define a virtual template from which this multilink PPP bundle interface can replicate its interface parameters. | 1600(config)#
| multilink virtual-template 1 | ||
| Configure the BRI interface to use the ISDN physical connection as a leased-line service. | 1600(config)#
| isdn leased-line BRI0 |
Use this table to configure the Ethernet interface with IP and IPX network addresses and for multilink PPP.
Step | Task | Router Prompt | Command | ||
---|---|---|---|---|---|
| Enter configuration mode for the Ethernet interface. | 1600(config)#
| interface Ethernet0 | ||
| Configure this interface with an IP address and a subnet mask. | 1600(config-if)#
| ip address 192.168.38.42 255.255.255.0 | ||
| Configure this interface with an IPX network address. | 1600(config-if)#
| ipx network ABC | ||
| Associate the virtual template with this virtual template interface. | 1600(config-if)#
| interface Virtual-Template1 | ||
| Configure the virtual template interface with an IP address and a subnet mask. | 1600(config-if)#
| ip address 192.168.40.40 255.255.255.0 | ||
| Configure the virtual template interface with an IPX network address. | 1600(config-if)#
| ipx network 123 | ||
| Set the encapsulation method on this interface to PPP. | 1600(config-if)#
| encapsulation ppp | ||
| Enable multilink PPP on this interface. | 1600(config-if)#
| ppp multilink | ||
| Enable the interface and the configuration changes you have just made on the interface. | 1600(config-if)#
| no shutdown | ||
| Exit configuration mode for this interface. | 1600(config-if)#
| exit |
Use this table to clear the IP address from the ISDN interface. In the following section, you configure two ISDN subinterfaces, which are used for sending data to the central site.
Step | Task | Router Prompt | Command | ||
| Enter configuration mode for the BRI interface. | 1600(config)#
| interface BRI0 | ||
| Disable IP routing on the BRI0 interface. | 1600(config-if)#
| no ip address | ||
| Exit configuration mode for this interface. | 1600(config-if)#
| exit |
Use this table to create and configure two ISDN subinterfaces, including the following:
Step | Task | Router Prompt | Command | ||
| Enter configuration mode for the BRI0:1 subinterface | 1600(config-if)#
| interface BRI0:1 | ||
| Enable IP routing on this interface without assigning an IP address. | 1600(config-if)#
| ip unnumbered Virtual-Template1 | ||
| Set the encapsulation method on this interface to PPP. | 1600(config-if)#
| encapsulation ppp | ||
| Enable multilink PPP on this interface. | 1600(config-if)#
| ppp multilink | ||
| Enter configuration mode for the BRI0:2 subinterface | 1600(config-if)#
| interface BRI0:2 | ||
| Enable IP routing on this interface without assigning an IP address. | 1600(config-if)#
| ip unnumbered Virtual-Template1 | ||
| Set the encapsulation method on this interface to PPP. | 1600(config-if)#
| encapsulation ppp | ||
| Enable multilink PPP on this interface. | 1600(config-if)#
| ppp multilink | ||
| Exit configuration mode for this interface. | 1600(config-if) | exit |
Use this table to configure the router for dynamic IP routing.
Step | Task | Router Prompt | Command | ||
| Configure the router to forward packets addressed to a subnet of a network with no network default route. | 1600(config)#
| ip classless | ||
| Specify dynamic routing. | 1600(config)#
| ip route 0.0.0.0 0.0.0.0 192.168.40.41 |
You can verify your configuration by confirming connectivity to the central-site router.
Step 1 From the privileged EXEC command mode, enter the ping command followed by the IP address of the central-site router:
192.168.37.40
Success rate is 80 percent
(4/5)
, round-trip min/avg/max = 40/43/48 ms
Step 2 Note the percentage in the "Success rate..." line (shown in bold in the example). A success rate of 60 percent (3/5) or greater means that your router is successfully transferring data to the central-site router.
Step 3 If the router is not successfully transferring data to the central-site router (if the success rate is less than 60 percent), take the following steps:
Step 4 To continue configuration, re-enter global configuration mode.
Use this table to configure some parameters that control access to the router, including the type of terminal line used with the router, how long the router waits for a user entry before it times out, and the password used to start a terminal session with the router.
Step | Task | Router Prompt | Command | ||
| Specify the console terminal line. | 1600(config)#
| line console 0 | ||
| Set the interval that the EXEC command interpreter waits until user input is detected. | 1600(config-line)#
| exec-timeout 5 | ||
| Specify a virtual terminal for remote console access. | 1600(config-line)#
| line vty 0 4 | ||
| Specify a password on the line. | 1600(config-line)#
| password lineaccess | ||
| Enable password checking at terminal session login. | 1600(config-line)#
| login | ||
| Exit configuration mode. | 1600(config-line)#
| end |
If you are having problems or the output that you received during the verification steps is very different from what is shown, you can troubleshoot your router with the Cisco IOS debug commands. The debug commands provide extensive command output that is not included in this document.
![]() | Caution If you are not familiar with Cisco IOS debug commands, you should read the "Using Debug Commands" section in the "Cisco IOS Basic Skills" chapter before attempting any debugging. |
Following is the debug command that is helpful when troubleshooting dialer profiles with ISDN. Follow this command with the ping command to begin debug output:
ISDN is a set of digital services that is available through your local telephone company. ISDN digitizes information that is sent over the telephone network so that voice, data, text, graphics, music, video, and other material can be sent over existing telephone wire.
ISDN components include terminals, terminal adapters (TAs), network termination devices, line-termination equipment, and exchange-termination equipment.
There are two type of ISDN terminals:
There are two types of ISDN terminal devices used to connect your router to the telephone company conventional 2-wire local loop:
There is also a NT-1/2 device that performs both the functions of an NT-1 and an NT-2.
Figure 3-4 shows a sample ISDN configuration with the devices used to connect the user to the ISDN network.
Two of the devices shown, the computer and the ISDN telephone, are compatible with ISDN. The third device, the standard telephone, requires a TA to connect to the ISDN network through an NT-2 or NT-1 device.
There are two types of ISDN services:
![]() ![]() ![]() ![]() ![]() ![]() ![]() ![]() |